GoogleFiMag Namespace

[image]

Documentation of GoogleFiMag
GoogleFiMag Namespace
Send Feedback

[Missing <summary> documentation for "N:GoogleFiMag"]

Classes

 | Class | Description
Public class | ConnectivityException | Exception to handle the connectivity, you have to but connected to use this DLL
Public class | DataFI | Class which allow you to stock the historical datas that you retrive from the internet. There is a lot of fonction that allow you to get what you need after you created the object itself. This class is mainly about the matrix mat_valeurs with every data in it
Public class | GoogleFI | This classes allows you to use all of the export methods of the GoogleFiMag dll. In order to instance this classes, you have to indicate the starting date and the ending date of the period for recovering data from Google Finance. You also have to specifiy if you want daily or weekly data. Finally, you have to indicate the list of indexes you want infos on. GoogleFI class provides a lot of export methods in different formats such as XML, CSV, MDF or double matrix. It is possible to obtains information about every official Reuter indexes, since it's recorded on Google Finance server. Datas are "Open" : open price for a specific day "Close" : closing price for an index. "Low" and "High" for a day and an index, and "Volume" which is the number of transactions for an index on a day.
Public class | historique |
Public class | linkDataContext |
Public class | parserxml | Parses a xml file
Public class | UnknownIndexException | Exception thrown when the index is unknown on GOOGLE FINANCE

Alexandre Ohayon, Tristan Gueguen, Ari Amsellem


ConnectivityException Class

[image]

Documentation of GoogleFiMag
ConnectivityException Class
Members See Also Send Feedback
Exception to handle the connectivity, you have to but connected to use this DLL

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConnectivityException : Exception
Visual Basic
Public Class ConnectivityException _
    Inherits Exception
Visual C++
public ref class ConnectivityException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
GoogleFiMag..::..ConnectivityException

See Also

ConnectivityException Members
GoogleFiMag Namespace


ConnectivityException Members

[image] [image]

Documentation of GoogleFiMag
ConnectivityException Members
ConnectivityException Class Constructors Methods Properties Events See Also Send Feedback

The ConnectivityException type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectivityException()()()() | Constructor
Public method | ConnectivityException(String) | Constructor where you can specify the message

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Protected property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | (Inherited from Exception.)

See Also

ConnectivityException Class


ConnectivityException Constructor

[image] [image]

Documentation of GoogleFiMag
ConnectivityException Constructor
ConnectivityException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConnectivityException()()()() | Constructor
Public method | ConnectivityException(String) | Constructor where you can specify the message

See Also

ConnectivityException Class
ConnectivityException Members


ConnectivityException Constructor

[image]

Documentation of GoogleFiMag
ConnectivityException Constructor
ConnectivityException Class See Also Send Feedback
Constructor

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnectivityException()
Visual Basic
Public Sub New
Visual C++
public:
ConnectivityException()

See Also

ConnectivityException Class
ConnectivityException Overload


ConnectivityException Constructor (String)

[image]

Documentation of GoogleFiMag
ConnectivityException Constructor (String)
ConnectivityException Class See Also Send Feedback
Constructor where you can specify the message

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnectivityException(
    string Message
)
Visual Basic
Public Sub New ( _
    Message As String _
)
Visual C++
public:
ConnectivityException(
    String^ Message
)

Parameters

Message
Type: System..::..String
message you want to put

See Also

ConnectivityException Class
ConnectivityException Overload


ConnectivityException Methods

[image] [image]

Documentation of GoogleFiMag
ConnectivityException Methods
ConnectivityException Class See Also Send Feedback

The ConnectivityException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)

See Also

ConnectivityException Class


ConnectivityException Properties

[image] [image]

Documentation of GoogleFiMag
ConnectivityException Properties
ConnectivityException Class See Also Send Feedback

The ConnectivityException type exposes the following members.

Properties

 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Protected property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)

See Also

ConnectivityException Class


ConnectivityException Events

[image] [image]

Documentation of GoogleFiMag
ConnectivityException Events
ConnectivityException Class See Also Send Feedback

The ConnectivityException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | (Inherited from Exception.)

See Also

ConnectivityException Class


DataFI Class

[image]

Documentation of GoogleFiMag
DataFI Class
Members See Also Send Feedback
Class which allow you to stock the historical datas that you retrive from the internet. There is a lot of fonction that allow you to get what you need after you created the object itself. This class is mainly about the matrix mat_valeurs with every data in it

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DataFI
Visual Basic
Public Class DataFI
Visual C++
public ref class DataFI

Inheritance Hierarchy

System..::..Object
GoogleFiMag..::..DataFI

See Also

DataFI Members


DataFI Members

[image] [image]

Documentation of GoogleFiMag
DataFI Members
DataFI Class Constructors Methods See Also Send Feedback

The DataFI type exposes the following members.

Constructors

 | Name | Description
Public method | DataFI()()()() | Default constructor
Public method | DataFI(array<String>[]()[][], array<DateTime>[]()[][]) | Second construtor which alors to fill tab_dates and tab_index. And create tab_donnee with every donnee (Low,High,Close,Volume,Open) possible
Public method | DataFI(array<String>[]()[][], array<DateTime>[]()[][], array<String>[]()[][]) | Constructor where you can specify the donnee (Low,High...) that you want in a tab

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | getData | get the tab tab_donnee
Public method | getdates | get the tab tab_dates
Public method | GetHashCode | (Inherited from Object.)
Public method | getMatOneData(Int32) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | getMatOneData(String) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | getMatOneIndex(Int32) | Get a bidimentional matrix of values for a specific index (GOOG, AAPL...)
Public method | getMatOneIndex(String) | Get a bidimentional matrix of values for a specific index (GOOG, AAPL...)
Public method | getsizetab | to get the size of a tab 0)sizeof tab_index, 1)sizeof tab_dates, 2)sizeof tab_donnee.
Public method | getSpecificData(String, array<String>[]()[][]) | Get a data with a tab of donnee
Public method | getSpecificData(Int32, Int32, Int32, Int32, Int32) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)
Public method | getSpecificData(Int32, String, String, String, String) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)
Public method | getSpecificData(String, String, String, String, String) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)
Public method | GetType | (Inherited from Object.)
Public method | getVal(Int32, Int32, Int32) | Same function that before (getVal) but with rank in the tabs(tab_index,tab_dates,tab_donnee)
Public method | getVal(String, DateTime, String) | Get a values from the matrix mat_valeurs
Public method | Hashdate | to get the place of a specific date
Public method | Hashdonnee | Give the rank of a donnee (for exemple Low, High) in tab_donnee
Public method | Hashindex | Allow to get the number au the index in tab_index
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | outputmat()()()() | output the 3-D mat in Console
Public method | outputmat(Int32) | Output the bidimentional mat with a specific index in Console
Public method | putDataIn | To put data in the matrix mat_valeurs
Public method | ReverseHashdonnee | give the donnee in string from a int
Public method | ToString | (Inherited from Object.)

See Also

DataFI Class


DataFI Constructor

[image] [image]

Documentation of GoogleFiMag
DataFI Constructor
DataFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataFI()()()() | Default constructor
Public method | DataFI(array<String>[]()[][], array<DateTime>[]()[][]) | Second construtor which alors to fill tab_dates and tab_index. And create tab_donnee with every donnee (Low,High,Close,Volume,Open) possible
Public method | DataFI(array<String>[]()[][], array<DateTime>[]()[][], array<String>[]()[][]) | Constructor where you can specify the donnee (Low,High...) that you want in a tab

See Also

DataFI Class
DataFI Members


DataFI Constructor

[image]

Documentation of GoogleFiMag
DataFI Constructor
DataFI Class See Also Send Feedback
Default constructor

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataFI()
Visual Basic
Public Sub New
Visual C++
public:
DataFI()

See Also

DataFI Class
DataFI Overload


DataFI Constructor (String[], DateTime[])

[image]

Documentation of GoogleFiMag
DataFI Constructor (array<String>[]()[][], array<DateTime>[]()[][])
DataFI Class See Also Send Feedback
Second construtor which alors to fill tab_dates and tab_index. And create tab_donnee with every donnee (Low,High,Close,Volume,Open) possible

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataFI(
    string[] tab_ind,
    DateTime[] tab_d
)
Visual Basic
Public Sub New ( _
    tab_ind As String(), _
    tab_d As DateTime() _
)
Visual C++
public:
DataFI(
    array<String^>^ tab_ind,
    array<DateTime>^ tab_d
)

Parameters

tab_ind
Type: array< System..::..String >[]()[][]
it's tab_index
tab_d
Type: array< System..::..DateTime >[]()[][]
it's tab_data

See Also

DataFI Class
DataFI Overload


DataFI Constructor (String[], DateTime[], String[])

[image]

Documentation of GoogleFiMag
DataFI Constructor (array<String>[]()[][], array<DateTime>[]()[][], array<String>[]()[][])
DataFI Class See Also Send Feedback
Constructor where you can specify the donnee (Low,High...) that you want in a tab

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataFI(
    string[] tab_ind,
    DateTime[] tab_d,
    string[] tab_donnee_in
)
Visual Basic
Public Sub New ( _
    tab_ind As String(), _
    tab_d As DateTime(), _
    tab_donnee_in As String() _
)
Visual C++
public:
DataFI(
    array<String^>^ tab_ind,
    array<DateTime>^ tab_d,
    array<String^>^ tab_donnee_in
)

Parameters

tab_ind
Type: array< System..::..String >[]()[][]
tab_index
tab_d
Type: array< System..::..DateTime >[]()[][]
tab_dates
tab_donnee_in
Type: array< System..::..String >[]()[][]
tab_donnee

See Also

DataFI Class
DataFI Overload


DataFI Methods

[image] [image]

Documentation of GoogleFiMag
DataFI Methods
DataFI Class See Also Send Feedback

The DataFI type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | getData | get the tab tab_donnee
Public method | getdates | get the tab tab_dates
Public method | GetHashCode | (Inherited from Object.)
Public method | getMatOneData(Int32) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | getMatOneData(String) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | getMatOneIndex(Int32) | Get a bidimentional matrix of values for a specific index (GOOG, AAPL...)
Public method | getMatOneIndex(String) | Get a bidimentional matrix of values for a specific index (GOOG, AAPL...)
Public method | getsizetab | to get the size of a tab 0)sizeof tab_index, 1)sizeof tab_dates, 2)sizeof tab_donnee.
Public method | getSpecificData(String, array<String>[]()[][]) | Get a data with a tab of donnee
Public method | getSpecificData(Int32, Int32, Int32, Int32, Int32) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)
Public method | getSpecificData(Int32, String, String, String, String) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)
Public method | getSpecificData(String, String, String, String, String) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)
Public method | GetType | (Inherited from Object.)
Public method | getVal(Int32, Int32, Int32) | Same function that before (getVal) but with rank in the tabs(tab_index,tab_dates,tab_donnee)
Public method | getVal(String, DateTime, String) | Get a values from the matrix mat_valeurs
Public method | Hashdate | to get the place of a specific date
Public method | Hashdonnee | Give the rank of a donnee (for exemple Low, High) in tab_donnee
Public method | Hashindex | Allow to get the number au the index in tab_index
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | outputmat()()()() | output the 3-D mat in Console
Public method | outputmat(Int32) | Output the bidimentional mat with a specific index in Console
Public method | putDataIn | To put data in the matrix mat_valeurs
Public method | ReverseHashdonnee | give the donnee in string from a int
Public method | ToString | (Inherited from Object.)

See Also

DataFI Class


getData Method

[image]

Documentation of GoogleFiMag
DataFI..::..getData Method
DataFI Class See Also Send Feedback
get the tab tab_donnee

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string[] getData()
Visual Basic
Public Function getData As String()
Visual C++
public:
array<String^>^ getData()

Return Value

tab_donnee

See Also

DataFI Class


getdates Method

[image]

Documentation of GoogleFiMag
DataFI..::..getdates Method
DataFI Class See Also Send Feedback
get the tab tab_dates

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime[] getdates()
Visual Basic
Public Function getdates As DateTime()
Visual C++
public:
array<DateTime>^ getdates()

Return Value

tab_dates

See Also

DataFI Class


getMatOneData Method

[image] [image]

Documentation of GoogleFiMag
DataFI..::..getMatOneData Method
DataFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | getMatOneData(Int32) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | getMatOneData(String) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters

See Also

DataFI Class
DataFI Members


getMatOneData Method (Int32)

[image]

Documentation of GoogleFiMag
DataFI..::..getMatOneData Method (Int32)
DataFI Class See Also Send Feedback
Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] getMatOneData(
    int data
)
Visual Basic
Public Function getMatOneData ( _
    data As Integer _
) As Double(,)
Visual C++
public:
array<double,2>^ getMatOneData(
    int data
)

Parameters

data
Type: System..::..Int32
the rank of the data that you need

Examples

Low, High...
in the tab of datas

Return Value

a double[index,date]

See Also

DataFI Class
getMatOneData Overload


getMatOneData Method (String)

[image]

Documentation of GoogleFiMag
DataFI..::..getMatOneData Method (String)
DataFI Class See Also Send Feedback
Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] getMatOneData(
    string data
)
Visual Basic
Public Function getMatOneData ( _
    data As String _
) As Double(,)
Visual C++
public:
array<double,2>^ getMatOneData(
    String^ data
)

Parameters

data
Type: System..::..String
the stirng of the data you need

Examples

Low, High...

Return Value

a double[index,date]

See Also

DataFI Class
getMatOneData Overload


getMatOneIndex Method

[image] [image]

Documentation of GoogleFiMag
DataFI..::..getMatOneIndex Method
DataFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | getMatOneIndex(Int32) | Get a bidimentional matrix of values for a specific index (GOOG, AAPL...)
Public method | getMatOneIndex(String) | Get a bidimentional matrix of values for a specific index (GOOG, AAPL...)

See Also

DataFI Class
DataFI Members


getMatOneIndex Method (Int32)

[image]

Documentation of GoogleFiMag
DataFI..::..getMatOneIndex Method (Int32)
DataFI Class See Also Send Feedback
Get a bidimentional matrix of values for a specific index (GOOG, AAPL...)

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] getMatOneIndex(
    int index
)
Visual Basic
Public Function getMatOneIndex ( _
    index As Integer _
) As Double(,)
Visual C++
public:
array<double,2>^ getMatOneIndex(
    int index
)

Parameters

index
Type: System..::..Int32
The index that you need the bidimentional matrix, rank onf the index in tab_index

Return Value

a matrix with the values (double[dates,donnee])

See Also

DataFI Class
getMatOneIndex Overload


getMatOneIndex Method (String)

[image]

Documentation of GoogleFiMag
DataFI..::..getMatOneIndex Method (String)
DataFI Class See Also Send Feedback
Get a bidimentional matrix of values for a specific index (GOOG, AAPL...)

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] getMatOneIndex(
    string index
)
Visual Basic
Public Function getMatOneIndex ( _
    index As String _
) As Double(,)
Visual C++
public:
array<double,2>^ getMatOneIndex(
    String^ index
)

Parameters

index
Type: System..::..String
The index that you need the bidimentional matrix but in string

Return Value

a matrix with the values (double[dates,donnee])

See Also

DataFI Class
getMatOneIndex Overload


getsizetab Method

[image]

Documentation of GoogleFiMag
DataFI..::..getsizetab Method
DataFI Class See Also Send Feedback
to get the size of a tab 0)sizeof tab_index, 1)sizeof tab_dates, 2)sizeof tab_donnee.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int getsizetab(
    int i
)
Visual Basic
Public Function getsizetab ( _
    i As Integer _
) As Integer
Visual C++
public:
int getsizetab(
    int i
)

Parameters

i
Type: System..::..Int32
0,1,2

Return Value

the size of the tab in param of the class

See Also

DataFI Class


getSpecificData Method

[image] [image]

Documentation of GoogleFiMag
DataFI..::..getSpecificData Method
DataFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | getSpecificData(String, array<String>[]()[][]) | Get a data with a tab of donnee
Public method | getSpecificData(Int32, Int32, Int32, Int32, Int32) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)
Public method | getSpecificData(Int32, String, String, String, String) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)
Public method | getSpecificData(String, String, String, String, String) | Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)

See Also

DataFI Class
DataFI Members


getSpecificData Method (String, String[])

[image]

Documentation of GoogleFiMag
DataFI..::..getSpecificData Method (String, array<String>[]()[][])
DataFI Class See Also Send Feedback
Get a data with a tab of donnee

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] getSpecificData(
    string index,
    string[] Arg1
)
Visual Basic
Public Function getSpecificData ( _
    index As String, _
    Arg1 As String() _
) As Double(,)
Visual C++
public:
array<double,2>^ getSpecificData(
    String^ index,
    array<String^>^ Arg1
)

Parameters

index
Type: System..::..String
the index that you want to have the datas
Arg1
Type: array< System..::..String >[]()[][]
tab of donnee(Low,High,Close,Open,Volume)

Return Value

the bidimentional tab of datas

See Also

DataFI Class
getSpecificData Overload


getSpecificData Method (Int32, Int32, Int32, Int32, Int32)

[image]

Documentation of GoogleFiMag
DataFI..::..getSpecificData Method (Int32, Int32, Int32, Int32, Int32)
DataFI Class See Also Send Feedback
Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] getSpecificData(
    int index,
    int Arg1,
    int Arg2,
    int Arg3,
    int Arg4
)
Visual Basic
Public Function getSpecificData ( _
    index As Integer, _
    Arg1 As Integer, _
    Arg2 As Integer, _
    Arg3 As Integer, _
    Arg4 As Integer _
) As Double(,)
Visual C++
public:
array<double,2>^ getSpecificData(
    int index,
    int Arg1,
    int Arg2,
    int Arg3,
    int Arg4
)

Parameters

index
Type: System..::..Int32
the index you want the datas
Arg1
Type: System..::..Int32
one of the donnee you need
Arg2
Type: System..::..Int32
one of the donnee you need (optional)
Arg3
Type: System..::..Int32
one of the donnee you need (optional)
Arg4
Type: System..::..Int32
one of the donnee you need (optional)

Return Value

tab of values with specific donnee

Remarks

if you need all the 5 donnee don't use this fonction but getMatOneIndex

See Also

DataFI Class
getSpecificData Overload


getSpecificData Method (Int32, String, String, String, String)

[image]

Documentation of GoogleFiMag
DataFI..::..getSpecificData Method (Int32, String, String, String, String)
DataFI Class See Also Send Feedback
Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] getSpecificData(
    int index,
    string Arg1,
    string Arg2,
    string Arg3,
    string Arg4
)
Visual Basic
Public Function getSpecificData ( _
    index As Integer, _
    Arg1 As String, _
    Arg2 As String, _
    Arg3 As String, _
    Arg4 As String _
) As Double(,)
Visual C++
public:
array<double,2>^ getSpecificData(
    int index,
    String^ Arg1,
    String^ Arg2,
    String^ Arg3,
    String^ Arg4
)

Parameters

index
Type: System..::..Int32
the index you want the datas
Arg1
Type: System..::..String
one of the donnee you need
Arg2
Type: System..::..String
one of the donnee you need (optional)
Arg3
Type: System..::..String
one of the donnee you need (optional)
Arg4
Type: System..::..String
one of the donnee you need (optional)

Return Value

tab of values with specific donnee

Remarks

if you need all the 5 donnee don't use this fonction but getMatOneIndex

See Also

DataFI Class
getSpecificData Overload


getSpecificData Method (String, String, String, String, String)

[image]

Documentation of GoogleFiMag
DataFI..::..getSpecificData Method (String, String, String, String, String)
DataFI Class See Also Send Feedback
Get a bidimentional tab, for a specific index, and specific donnee(Low,High,...)

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] getSpecificData(
    string index,
    string Arg1,
    string Arg2,
    string Arg3,
    string Arg4
)
Visual Basic
Public Function getSpecificData ( _
    index As String, _
    Arg1 As String, _
    Arg2 As String, _
    Arg3 As String, _
    Arg4 As String _
) As Double(,)
Visual C++
public:
array<double,2>^ getSpecificData(
    String^ index,
    String^ Arg1,
    String^ Arg2,
    String^ Arg3,
    String^ Arg4
)

Parameters

index
Type: System..::..String
the index you want the datas
Arg1
Type: System..::..String
one of the donnee you need
Arg2
Type: System..::..String
one of the donnee you need (optional)
Arg3
Type: System..::..String
one of the donnee you need (optional)
Arg4
Type: System..::..String
one of the donnee you need (optional)

Return Value

tab of values with specific donnee

Remarks

if you need all the 5 donnee don't use this fonction but getMatOneIndex

See Also

DataFI Class
getSpecificData Overload


getVal Method

[image] [image]

Documentation of GoogleFiMag
DataFI..::..getVal Method
DataFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | getVal(Int32, Int32, Int32) | Same function that before (getVal) but with rank in the tabs(tab_index,tab_dates,tab_donnee)
Public method | getVal(String, DateTime, String) | Get a values from the matrix mat_valeurs

See Also

DataFI Class
DataFI Members


getVal Method (Int32, Int32, Int32)

[image]

Documentation of GoogleFiMag
DataFI..::..getVal Method (Int32, Int32, Int32)
DataFI Class See Also Send Feedback
Same function that before (getVal) but with rank in the tabs(tab_index,tab_dates,tab_donnee)

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double getVal(
    int index,
    int date,
    int donnee
)
Visual Basic
Public Function getVal ( _
    index As Integer, _
    date As Integer, _
    donnee As Integer _
) As Double
Visual C++
public:
double getVal(
    int index,
    int date,
    int donnee
)

Parameters

index
Type: System..::..Int32
rank in tab_index
date
Type: System..::..Int32
rank in tab_dates
donnee
Type: System..::..Int32
rank in tab_donnee

Return Value

the values in double

See Also

DataFI Class
getVal Overload


getVal Method (String, DateTime, String)

[image]

Documentation of GoogleFiMag
DataFI..::..getVal Method (String, DateTime, String)
DataFI Class See Also Send Feedback
Get a values from the matrix mat_valeurs

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double getVal(
    string s,
    DateTime d,
    string donnee
)
Visual Basic
Public Function getVal ( _
    s As String, _
    d As DateTime, _
    donnee As String _
) As Double
Visual C++
public:
double getVal(
    String^ s,
    DateTime d,
    String^ donnee
)

Parameters

s
Type: System..::..String
the string of the index (GOOG,AAPL...)
d
Type: System..::..DateTime
the date (in datetimes
donnee
Type: System..::..String
the donee (Low,High...)

Return Value

the values in double

See Also

DataFI Class
getVal Overload


Hashdate Method

[image]

Documentation of GoogleFiMag
DataFI..::..Hashdate Method
DataFI Class See Also Send Feedback
to get the place of a specific date

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Hashdate(
    DateTime d
)
Visual Basic
Public Function Hashdate ( _
    d As DateTime _
) As Integer
Visual C++
public:
int Hashdate(
    DateTime d
)

Parameters

d
Type: System..::..DateTime
the date that you are looking the rank in the tab tab_dates

Return Value

the rank of d

Remarks

Return -1 if there is an error

See Also

DataFI Class


Hashdonnee Method

[image]

Documentation of GoogleFiMag
DataFI..::..Hashdonnee Method
DataFI Class See Also Send Feedback
Give the rank of a donnee (for exemple Low, High) in tab_donnee

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Hashdonnee(
    string donnee
)
Visual Basic
Public Function Hashdonnee ( _
    donnee As String _
) As Integer
Visual C++
public:
int Hashdonnee(
    String^ donnee
)

Parameters

donnee
Type: System..::..String
the string you are looking for the rank

Return Value

[Missing <returns> documentation for "M:GoogleFiMag.DataFI.Hashdonnee(System.String)"]

Remarks

Return -1 if there is an error

See Also

DataFI Class


Hashindex Method

[image]

Documentation of GoogleFiMag
DataFI..::..Hashindex Method
DataFI Class See Also Send Feedback
Allow to get the number au the index in tab_index

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Hashindex(
    string reuter
)
Visual Basic
Public Function Hashindex ( _
    reuter As String _
) As Integer
Visual C++
public:
int Hashindex(
    String^ reuter
)

Parameters

reuter
Type: System..::..String
string of the index you are looking for

Return Value

place of this index in tab_index

Remarks

Return -1 if there if an error

See Also

DataFI Class


outputmat Method

[image] [image]

Documentation of GoogleFiMag
DataFI..::..outputmat Method
DataFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | outputmat()()()() | output the 3-D mat in Console
Public method | outputmat(Int32) | Output the bidimentional mat with a specific index in Console

See Also

DataFI Class
DataFI Members


outputmat Method

[image]

Documentation of GoogleFiMag
DataFI..::..outputmat Method
DataFI Class See Also Send Feedback
output the 3-D mat in Console

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void outputmat()
Visual Basic
Public Sub outputmat
Visual C++
public:
void outputmat()

Remarks

Use it just for testing

See Also

DataFI Class
outputmat Overload


outputmat Method (Int32)

[image]

Documentation of GoogleFiMag
DataFI..::..outputmat Method (Int32)
DataFI Class See Also Send Feedback
Output the bidimentional mat with a specific index in Console

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void outputmat(
    int index
)
Visual Basic
Public Sub outputmat ( _
    index As Integer _
)
Visual C++
public:
void outputmat(
    int index
)

Parameters

index
Type: System..::..Int32
the index of the mat you need to output

Remarks

Use it just for testing

See Also

DataFI Class
outputmat Overload


putDataIn Method

[image]

Documentation of GoogleFiMag
DataFI..::..putDataIn Method
DataFI Class See Also Send Feedback
To put data in the matrix mat_valeurs

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void putDataIn(
    int indiceIndex,
    double[,] tabval
)
Visual Basic
Public Sub putDataIn ( _
    indiceIndex As Integer, _
    tabval As Double(,) _
)
Visual C++
public:
void putDataIn(
    int indiceIndex,
    array<double,2>^ tabval
)

Parameters

indiceIndex
Type: System..::..Int32
place of the index in tab_index you need to add in mat_valeurs (you can put data in the matrix only index by index)
tabval
Type: array< System..::..Double ,2>[,](,)[,][,]
bidimentional matrix with datas you need to put in

See Also

DataFI Class


ReverseHashdonnee Method

[image]

Documentation of GoogleFiMag
DataFI..::..ReverseHashdonnee Method
DataFI Class See Also Send Feedback
give the donnee in string from a int

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ReverseHashdonnee(
    int i
)
Visual Basic
Public Function ReverseHashdonnee ( _
    i As Integer _
) As String
Visual C++
public:
String^ ReverseHashdonnee(
    int i
)

Parameters

i
Type: System..::..Int32
the rank of the donnee in tab_donnee

Return Value

the string

Remarks

Return Vide if there if a error

See Also

DataFI Class


GoogleFI Class

[image]

Documentation of GoogleFiMag
GoogleFI Class
Members See Also Send Feedback
This classes allows you to use all of the export methods of the GoogleFiMag dll. In order to instance this classes, you have to indicate the starting date and the ending date of the period for recovering data from Google Finance. You also have to specifiy if you want daily or weekly data. Finally, you have to indicate the list of indexes you want infos on. GoogleFI class provides a lot of export methods in different formats such as XML, CSV, MDF or double matrix. It is possible to obtains information about every official Reuter indexes, since it's recorded on Google Finance server. Datas are "Open" : open price for a specific day "Close" : closing price for an index. "Low" and "High" for a day and an index, and "Volume" which is the number of transactions for an index on a day.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GoogleFI
Visual Basic
Public Class GoogleFI
Visual C++
public ref class GoogleFI

Inheritance Hierarchy

System..::..Object
GoogleFiMag..::..GoogleFI

See Also

GoogleFI Members


GoogleFI Members

[image] [image]

Documentation of GoogleFiMag
GoogleFI Members
GoogleFI Class Constructors Methods See Also Send Feedback

The GoogleFI type exposes the following members.

Constructors

 | Name | Description
Public method | GoogleFI()()()() | Default constructor.
Public method | GoogleFI(String) | Constructor with an xml file in
Public method | GoogleFI(String, DateTime, DateTime, Int32) | Constructor which allows you to instanciate GoogleFI whith only an index. You don't have to create a tab of indexes.
Public method | GoogleFI(array<String>[]()[][], DateTime, DateTime, Int32) | Constructor with a tab of indexes.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | ExportCSV(Int32) | This method allows you to get a .csv file containing datas. You can open it with Excel.
Public method | ExportCSV(String) | This method allows you to get a .csv file containing datas. You can open it with Excel.
Public method | ExportCSV(Int32, array<String>[]()[][]) | This method allows you to create a .csv file containing data about your index, specifying options you want.
Public method | ExportCSV(String, array<String>[]()[][]) | This method allows you to create a .csv file containing data about your index, specifying options you want.
Public method | ExportDataFI()()()() | This method creates a DataFI instance using the GoogleFI attributes (such as frequency, start_date...)
Public method | ExportDataFI(array<String>[]()[][]) | This method creates a DataFI object allowing
Public method | ExportDB(array<String>[]()[][]) | Function which fills directly the given database
Public method | ExportDB(array<String>[]()[][], array<String>[]()[][]) | Function which fills directly the given database
Public method | ExportDouble(Int32) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ...
Public method | ExportDouble(String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ...
Public method | ExportDouble(Int32, Int32, Int32, Int32, Int32) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.
Public method | ExportDouble(Int32, String, String, String, String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.
Public method | ExportDouble(String, String, String, String, String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.
Public method | ExportDoubleOneData(Int32) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | ExportDoubleOneData(String) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | ExportMDF()()()() | This method allows you to get a .mdf file, which is a database image, containing all datas about your indexes. The .mdf file can be open in SQL by example.
Public method | ExportMDF(array<String>[]()[][]) | This method allows you to get a .mdf file, which is a database image, containing datas you want about your indexes. The .mdf file can be open in SQL by example.
Public method | ExportXML(Int32) | This method allows you to export datas about an index in a .xml file.
Public method | ExportXML(String) | This method allows you to export datas about an index in a .xml file.
Public method | ExportXML(Int32, array<String>[]()[][]) | This method allows you to export datas about an index in a .xml file, specifying options you want.
Public method | ExportXML(String, array<String>[]()[][]) | This method allows you to export datas about an index in a .xml file, specifying options you want.
Protected method | Finalize | (Inherited from Object.)
Public method | getCompName | get the name of the company when you give the ticker symbol
Public method | getend | access end
Public method | getfreq | access freq
Public method | GetHashCode | (Inherited from Object.)
Public method | getstart | access start
Public method | getTabIndex | access tab_index
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | set_GoogleFI | This method allows you to modify an instance of GoogleFI.
Public method | testIndex | Test if the reuters exists
Public method | ToString | (Inherited from Object.)

See Also

GoogleFI Class


GoogleFI Constructor

[image] [image]

Documentation of GoogleFiMag
GoogleFI Constructor
GoogleFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GoogleFI()()()() | Default constructor.
Public method | GoogleFI(String) | Constructor with an xml file in
Public method | GoogleFI(String, DateTime, DateTime, Int32) | Constructor which allows you to instanciate GoogleFI whith only an index. You don't have to create a tab of indexes.
Public method | GoogleFI(array<String>[]()[][], DateTime, DateTime, Int32) | Constructor with a tab of indexes.

See Also

GoogleFI Class
GoogleFI Members


GoogleFI Constructor

[image]

Documentation of GoogleFiMag
GoogleFI Constructor
GoogleFI Class See Also Send Feedback
Default constructor.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GoogleFI()
Visual Basic
Public Sub New
Visual C++
public:
GoogleFI()

Remarks

Useless. Don't use it.

See Also

GoogleFI Class
GoogleFI Overload


GoogleFI Constructor (String)

[image]

Documentation of GoogleFiMag
GoogleFI Constructor (String)
GoogleFI Class See Also Send Feedback
Constructor with an xml file in

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GoogleFI(
    string xmlfilename
)
Visual Basic
Public Sub New ( _
    xmlfilename As String _
)
Visual C++
public:
GoogleFI(
    String^ xmlfilename
)

Parameters

xmlfilename
Type: System..::..String
Xml file which you need to use

Remarks

XML file have a specific convention, read documentation to learn more

See Also

GoogleFI Class
GoogleFI Overload


GoogleFI Constructor (String, DateTime, DateTime, Int32)

[image]

Documentation of GoogleFiMag
GoogleFI Constructor (String, DateTime, DateTime, Int32)
GoogleFI Class See Also Send Feedback
Constructor which allows you to instanciate GoogleFI whith only an index. You don't have to create a tab of indexes.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GoogleFI(
    string index,
    DateTime datedebut,
    DateTime datefin,
    int frequence
)
Visual Basic
Public Sub New ( _
    index As String, _
    datedebut As DateTime, _
    datefin As DateTime, _
    frequence As Integer _
)
Visual C++
public:
GoogleFI(
    String^ index,
    DateTime datedebut,
    DateTime datefin,
    int frequence
)

Parameters

index
Type: System..::..String
String : Reuter name of the index
datedebut
Type: System..::..DateTime
Starting date of the period
datefin
Type: System..::..DateTime
Ending date of the period
frequence
Type: System..::..Int32
Frequency must be equals to 1 or 7 (daily or weekly

Exceptions

Exception | Condition
System..::..Exception | Throws an exception if you don't set frequency to 1 or 7.

See Also

GoogleFI Class
GoogleFI Overload


GoogleFI Constructor (String[], DateTime, DateTime, Int32)

[image]

Documentation of GoogleFiMag
GoogleFI Constructor (array<String>[]()[][], DateTime, DateTime, Int32)
GoogleFI Class See Also Send Feedback
Constructor with a tab of indexes.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GoogleFI(
    string[] tab_ind,
    DateTime datedebut,
    DateTime datefin,
    int frequence
)
Visual Basic
Public Sub New ( _
    tab_ind As String(), _
    datedebut As DateTime, _
    datefin As DateTime, _
    frequence As Integer _
)
Visual C++
public:
GoogleFI(
    array<String^>^ tab_ind,
    DateTime datedebut,
    DateTime datefin,
    int frequence
)

Parameters

tab_ind
Type: array< System..::..String >[]()[][]
Tab of Reuter names of indexes.
datedebut
Type: System..::..DateTime
Starting date
datefin
Type: System..::..DateTime
Ending date
frequence
Type: System..::..Int32
Frequency must be equals to 1 or 7 (daily or weekly

Exceptions

Exception | Condition
System..::..Exception | Throws an exception if you don't set frequency to 1 or 7.

See Also

GoogleFI Class
GoogleFI Overload


GoogleFI Methods

[image] [image]

Documentation of GoogleFiMag
GoogleFI Methods
GoogleFI Class See Also Send Feedback

The GoogleFI type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | ExportCSV(Int32) | This method allows you to get a .csv file containing datas. You can open it with Excel.
Public method | ExportCSV(String) | This method allows you to get a .csv file containing datas. You can open it with Excel.
Public method | ExportCSV(Int32, array<String>[]()[][]) | This method allows you to create a .csv file containing data about your index, specifying options you want.
Public method | ExportCSV(String, array<String>[]()[][]) | This method allows you to create a .csv file containing data about your index, specifying options you want.
Public method | ExportDataFI()()()() | This method creates a DataFI instance using the GoogleFI attributes (such as frequency, start_date...)
Public method | ExportDataFI(array<String>[]()[][]) | This method creates a DataFI object allowing
Public method | ExportDB(array<String>[]()[][]) | Function which fills directly the given database
Public method | ExportDB(array<String>[]()[][], array<String>[]()[][]) | Function which fills directly the given database
Public method | ExportDouble(Int32) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ...
Public method | ExportDouble(String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ...
Public method | ExportDouble(Int32, Int32, Int32, Int32, Int32) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.
Public method | ExportDouble(Int32, String, String, String, String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.
Public method | ExportDouble(String, String, String, String, String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.
Public method | ExportDoubleOneData(Int32) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | ExportDoubleOneData(String) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | ExportMDF()()()() | This method allows you to get a .mdf file, which is a database image, containing all datas about your indexes. The .mdf file can be open in SQL by example.
Public method | ExportMDF(array<String>[]()[][]) | This method allows you to get a .mdf file, which is a database image, containing datas you want about your indexes. The .mdf file can be open in SQL by example.
Public method | ExportXML(Int32) | This method allows you to export datas about an index in a .xml file.
Public method | ExportXML(String) | This method allows you to export datas about an index in a .xml file.
Public method | ExportXML(Int32, array<String>[]()[][]) | This method allows you to export datas about an index in a .xml file, specifying options you want.
Public method | ExportXML(String, array<String>[]()[][]) | This method allows you to export datas about an index in a .xml file, specifying options you want.
Protected method | Finalize | (Inherited from Object.)
Public method | getCompName | get the name of the company when you give the ticker symbol
Public method | getend | access end
Public method | getfreq | access freq
Public method | GetHashCode | (Inherited from Object.)
Public method | getstart | access start
Public method | getTabIndex | access tab_index
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | set_GoogleFI | This method allows you to modify an instance of GoogleFI.
Public method | testIndex | Test if the reuters exists
Public method | ToString | (Inherited from Object.)

See Also

GoogleFI Class


ExportCSV Method

[image] [image]

Documentation of GoogleFiMag
GoogleFI..::..ExportCSV Method
GoogleFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportCSV(Int32) | This method allows you to get a .csv file containing datas. You can open it with Excel.
Public method | ExportCSV(String) | This method allows you to get a .csv file containing datas. You can open it with Excel.
Public method | ExportCSV(Int32, array<String>[]()[][]) | This method allows you to create a .csv file containing data about your index, specifying options you want.
Public method | ExportCSV(String, array<String>[]()[][]) | This method allows you to create a .csv file containing data about your index, specifying options you want.

See Also

GoogleFI Class
GoogleFI Members


ExportCSV Method (Int32)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportCSV Method (Int32)
GoogleFI Class See Also Send Feedback
This method allows you to get a .csv file containing datas. You can open it with Excel.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportCSV(
    int index
)
Visual Basic
Public Function ExportCSV ( _
    index As Integer _
) As String
Visual C++
public:
String^ ExportCSV(
    int index
)

Parameters

index
Type: System..::..Int32
Rank of the index in tab_index

Return Value

Returns name of the .csv file.

See Also

GoogleFI Class
ExportCSV Overload


ExportCSV Method (String)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportCSV Method (String)
GoogleFI Class See Also Send Feedback
This method allows you to get a .csv file containing datas. You can open it with Excel.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportCSV(
    string index
)
Visual Basic
Public Function ExportCSV ( _
    index As String _
) As String
Visual C++
public:
String^ ExportCSV(
    String^ index
)

Parameters

index
Type: System..::..String
Reuter name of the index.

Return Value

Returns name of the .csv file.

See Also

GoogleFI Class
ExportCSV Overload


ExportCSV Method (Int32, String[])

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportCSV Method (Int32, array<String>[]()[][])
GoogleFI Class See Also Send Feedback
This method allows you to create a .csv file containing data about your index, specifying options you want.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportCSV(
    int index,
    string[] tab_donnee
)
Visual Basic
Public Function ExportCSV ( _
    index As Integer, _
    tab_donnee As String() _
) As String
Visual C++
public:
String^ ExportCSV(
    int index,
    array<String^>^ tab_donnee
)

Parameters

index
Type: System..::..Int32
Rank of the index in tab_index
tab_donnee
Type: array< System..::..String >[]()[][]
Tab containing options you want.

Return Value

Returns name of the .csv file.

See Also

GoogleFI Class
ExportCSV Overload


ExportCSV Method (String, String[])

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportCSV Method (String, array<String>[]()[][])
GoogleFI Class Example See Also Send Feedback
This method allows you to create a .csv file containing data about your index, specifying options you want.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportCSV(
    string index,
    string[] tab_donnee
)
Visual Basic
Public Function ExportCSV ( _
    index As String, _
    tab_donnee As String() _
) As String
Visual C++
public:
String^ ExportCSV(
    String^ index,
    array<String^>^ tab_donnee
)

Parameters

index
Type: System..::..String
Reuter name of the index you want.
tab_donnee
Type: array< System..::..String >[]()[][]
Tab containing options you want.

Return Value

Returns name of the .csv file.

Examples

How to use it
CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
string[] tab = new tab[2] { "High","Low" };
string s = g.ExportCSV("GOOG",tab);

See Also

GoogleFI Class
ExportCSV Overload


ExportDataFI Method

[image] [image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDataFI Method
GoogleFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportDataFI()()()() | This method creates a DataFI instance using the GoogleFI attributes (such as frequency, start_date...)
Public method | ExportDataFI(array<String>[]()[][]) | This method creates a DataFI object allowing

See Also

GoogleFI Class
GoogleFI Members


ExportDataFI Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDataFI Method
GoogleFI Class Example See Also Send Feedback
This method creates a DataFI instance using the GoogleFI attributes (such as frequency, start_date...)

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataFI ExportDataFI()
Visual Basic
Public Function ExportDataFI As DataFI
Visual C++
public:
DataFI^ ExportDataFI()

Return Value

This method returns a DataFI object which contains all datas from Google Finance

Examples

How to use it
CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
DataFI d = g.ExportDataFI();

See Also

GoogleFI Class
ExportDataFI Overload


ExportDataFI Method (String[])

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDataFI Method (array<String>[]()[][])
GoogleFI Class Example See Also Send Feedback
This method creates a DataFI object allowing

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataFI ExportDataFI(
    string[] tab_donnee
)
Visual Basic
Public Function ExportDataFI ( _
    tab_donnee As String() _
) As DataFI
Visual C++
public:
DataFI^ ExportDataFI(
    array<String^>^ tab_donnee
)

Parameters

tab_donnee
Type: array< System..::..String >[]()[][]
tab of String. Elements of this tab have to be "Low", "High", "Open", "Close" or "Volume"

Return Value

This method returns a DataFI object which contains all datas from Google Finance

Remarks

There is no exceptions thrown when you put some strings different from "Low", "High" etc. in your parameter tab, it will just be ignored. Better if you don't.

Examples

CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
string[] tab=new tab[2] { "High","Low","Volume" };
DataFI d = g.ExportDataFI();

See Also

GoogleFI Class
ExportDataFI Overload


ExportDB Method

[image] [image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDB Method
GoogleFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportDB(array<String>[]()[][]) | Function which fills directly the given database
Public method | ExportDB(array<String>[]()[][], array<String>[]()[][]) | Function which fills directly the given database

See Also

GoogleFI Class
GoogleFI Members


ExportDB Method (String[])

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDB Method (array<String>[]()[][])
GoogleFI Class See Also Send Feedback
Function which fills directly the given database

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportDB(
    string[] exportBDD
)
Visual Basic
Public Sub ExportDB ( _
    exportBDD As String() _
)
Visual C++
public:
void ExportDB(
    array<String^>^ exportBDD
)

Parameters

exportBDD
Type: array< System..::..String >[]()[][]
contains the parameters of the database

See Also

GoogleFI Class
ExportDB Overload


ExportDB Method (String[], String[])

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDB Method (array<String>[]()[][], array<String>[]()[][])
GoogleFI Class Example See Also Send Feedback
Function which fills directly the given database

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportDB(
    string[] tab_champ,
    string[] exportBDD
)
Visual Basic
Public Sub ExportDB ( _
    tab_champ As String(), _
    exportBDD As String() _
)
Visual C++
public:
void ExportDB(
    array<String^>^ tab_champ,
    array<String^>^ exportBDD
)

Parameters

tab_champ
Type: array< System..::..String >[]()[][]
contains the fields of observations
exportBDD
Type: array< System..::..String >[]()[][]
contains the parameters of the database

Examples

How to use it
CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
string[] tab = new tab[2] { "High","Low" };
string[] DB = new tab[3] { "localhost\SQLEXPRESS","BD_NAME", "Table_NAME" };
g.ExportDB(tab,DB);

See Also

GoogleFI Class
ExportDB Overload


ExportDouble Method

[image] [image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDouble Method
GoogleFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportDouble(Int32) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ...
Public method | ExportDouble(String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ...
Public method | ExportDouble(Int32, Int32, Int32, Int32, Int32) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.
Public method | ExportDouble(Int32, String, String, String, String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.
Public method | ExportDouble(String, String, String, String, String) | This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.

See Also

GoogleFI Class
GoogleFI Members


ExportDouble Method (Int32)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDouble Method (Int32)
GoogleFI Class Example See Also Send Feedback
This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ...

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] ExportDouble(
    int index
)
Visual Basic
Public Function ExportDouble ( _
    index As Integer _
) As Double(,)
Visual C++
public:
array<double,2>^ ExportDouble(
    int index
)

Parameters

index
Type: System..::..Int32
Integer which the rank of the index you want in tab_index

Return Value

Double matrix containing information

Examples

How to use it
CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
double[,] d = g.ExportDouble(i);

See Also

GoogleFI Class
ExportDouble Overload


ExportDouble Method (String)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDouble Method (String)
GoogleFI Class Example See Also Send Feedback
This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ...

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] ExportDouble(
    string index
)
Visual Basic
Public Function ExportDouble ( _
    index As String _
) As Double(,)
Visual C++
public:
array<double,2>^ ExportDouble(
    String^ index
)

Parameters

index
Type: System..::..String
Reuter name of the index you want.

Return Value

Double matrix containing information

Examples

How to use it
CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
double[,] d = g.ExportDouble("GOOG");

See Also

GoogleFI Class
ExportDouble Overload


ExportDouble Method (Int32, Int32, Int32, Int32, Int32)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDouble Method (Int32, Int32, Int32, Int32, Int32)
GoogleFI Class See Also Send Feedback
This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] ExportDouble(
    int index,
    int Arg1,
    int Arg2,
    int Arg3,
    int Arg4
)
Visual Basic
Public Function ExportDouble ( _
    index As Integer, _
    Arg1 As Integer, _
    Arg2 As Integer, _
    Arg3 As Integer, _
    Arg4 As Integer _
) As Double(,)
Visual C++
public:
array<double,2>^ ExportDouble(
    int index,
    int Arg1,
    int Arg2,
    int Arg3,
    int Arg4
)

Parameters

index
Type: System..::..Int32
Integer which the rank of the index you want in tab_index
Arg1
Type: System..::..Int32
First option index in tab of options you want
Arg2
Type: System..::..Int32
Second option index in tab of options you want. Optional
Arg3
Type: System..::..Int32
Third option index in tab of options you want. Optional
Arg4
Type: System..::..Int32
Fourth option index in tab of options you want. Optional

Return Value

Double matrix containing information

See Also

GoogleFI Class
ExportDouble Overload


ExportDouble Method (Int32, String, String, String, String)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDouble Method (Int32, String, String, String, String)
GoogleFI Class See Also Send Feedback
This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] ExportDouble(
    int index,
    string Arg1,
    string Arg2,
    string Arg3,
    string Arg4
)
Visual Basic
Public Function ExportDouble ( _
    index As Integer, _
    Arg1 As String, _
    Arg2 As String, _
    Arg3 As String, _
    Arg4 As String _
) As Double(,)
Visual C++
public:
array<double,2>^ ExportDouble(
    int index,
    String^ Arg1,
    String^ Arg2,
    String^ Arg3,
    String^ Arg4
)

Parameters

index
Type: System..::..Int32
Integer which the rank of the index you want in tab_index
Arg1
Type: System..::..String
First option you want
Arg2
Type: System..::..String
Second option you want. Optional
Arg3
Type: System..::..String
Third option you want. Optional
Arg4
Type: System..::..String
Fourth option you want. Optional

Return Value

Double matrix containing information

See Also

GoogleFI Class
ExportDouble Overload


ExportDouble Method (String, String, String, String, String)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDouble Method (String, String, String, String, String)
GoogleFI Class See Also Send Feedback
This method creates a double matrix (bi-dimensionnal), containing datas for an index. First dimension is for dates and second is for "Open", "Low" ... If you don't want to get datas for 5 options (Low, High ...) you can use this fonction specifying one, two, three or four options.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] ExportDouble(
    string index,
    string Arg1,
    string Arg2,
    string Arg3,
    string Arg4
)
Visual Basic
Public Function ExportDouble ( _
    index As String, _
    Arg1 As String, _
    Arg2 As String, _
    Arg3 As String, _
    Arg4 As String _
) As Double(,)
Visual C++
public:
array<double,2>^ ExportDouble(
    String^ index,
    String^ Arg1,
    String^ Arg2,
    String^ Arg3,
    String^ Arg4
)

Parameters

index
Type: System..::..String
Reuter name of the index you want.
Arg1
Type: System..::..String
First option you want
Arg2
Type: System..::..String
Second option you want. Optional
Arg3
Type: System..::..String
Third option you want. Optional
Arg4
Type: System..::..String
Fourth option you want. Optional

Return Value

Double matrix containing information

See Also

GoogleFI Class
ExportDouble Overload


ExportDoubleOneData Method

[image] [image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDoubleOneData Method
GoogleFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportDoubleOneData(Int32) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters
Public method | ExportDoubleOneData(String) | Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters

See Also

GoogleFI Class
GoogleFI Members


ExportDoubleOneData Method (Int32)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDoubleOneData Method (Int32)
GoogleFI Class See Also Send Feedback
Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] ExportDoubleOneData(
    int dataname
)
Visual Basic
Public Function ExportDoubleOneData ( _
    dataname As Integer _
) As Double(,)
Visual C++
public:
array<double,2>^ ExportDoubleOneData(
    int dataname
)

Parameters

dataname
Type: System..::..Int32
the rank of the data that you need

Examples

Low, High...
in the tab of datas

Return Value

a double[index,date]

See Also

GoogleFI Class
ExportDoubleOneData Overload


ExportDoubleOneData Method (String)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportDoubleOneData Method (String)
GoogleFI Class Example See Also Send Feedback
Fonction who gives you a bidimentional matrix with the dates in function of the indexes Reuters

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[,] ExportDoubleOneData(
    string dataname
)
Visual Basic
Public Function ExportDoubleOneData ( _
    dataname As String _
) As Double(,)
Visual C++
public:
array<double,2>^ ExportDoubleOneData(
    String^ dataname
)

Parameters

dataname
Type: System..::..String
the string name of the data that you need

Examples

Low, High...

Return Value

a double[index,date]

Examples

How to use it
CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
double[,] d = g.ExportDoubleOneData("High");

See Also

GoogleFI Class
ExportDoubleOneData Overload


ExportMDF Method

[image] [image]

Documentation of GoogleFiMag
GoogleFI..::..ExportMDF Method
GoogleFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportMDF()()()() | This method allows you to get a .mdf file, which is a database image, containing all datas about your indexes. The .mdf file can be open in SQL by example.
Public method | ExportMDF(array<String>[]()[][]) | This method allows you to get a .mdf file, which is a database image, containing datas you want about your indexes. The .mdf file can be open in SQL by example.

See Also

GoogleFI Class
GoogleFI Members


ExportMDF Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportMDF Method
GoogleFI Class See Also Send Feedback
This method allows you to get a .mdf file, which is a database image, containing all datas about your indexes. The .mdf file can be open in SQL by example.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportMDF()
Visual Basic
Public Function ExportMDF As String
Visual C++
public:
String^ ExportMDF()

Return Value

Name of the .mdf

See Also

GoogleFI Class
ExportMDF Overload


ExportMDF Method (String[])

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportMDF Method (array<String>[]()[][])
GoogleFI Class Example See Also Send Feedback
This method allows you to get a .mdf file, which is a database image, containing datas you want about your indexes. The .mdf file can be open in SQL by example.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportMDF(
    string[] tab_donnee
)
Visual Basic
Public Function ExportMDF ( _
    tab_donnee As String() _
) As String
Visual C++
public:
String^ ExportMDF(
    array<String^>^ tab_donnee
)

Parameters

tab_donnee
Type: array< System..::..String >[]()[][]
Options you want in a string tab.

Return Value

Name of the .mdf

Examples

How to use it
CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
string[] tab = new tab[2] { "High","Low" };
string s = g.ExportMDF(tab);

See Also

GoogleFI Class
ExportMDF Overload


ExportXML Method

[image] [image]

Documentation of GoogleFiMag
GoogleFI..::..ExportXML Method
GoogleFI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportXML(Int32) | This method allows you to export datas about an index in a .xml file.
Public method | ExportXML(String) | This method allows you to export datas about an index in a .xml file.
Public method | ExportXML(Int32, array<String>[]()[][]) | This method allows you to export datas about an index in a .xml file, specifying options you want.
Public method | ExportXML(String, array<String>[]()[][]) | This method allows you to export datas about an index in a .xml file, specifying options you want.

See Also

GoogleFI Class
GoogleFI Members


ExportXML Method (Int32)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportXML Method (Int32)
GoogleFI Class See Also Send Feedback
This method allows you to export datas about an index in a .xml file.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportXML(
    int index
)
Visual Basic
Public Function ExportXML ( _
    index As Integer _
) As String
Visual C++
public:
String^ ExportXML(
    int index
)

Parameters

index
Type: System..::..Int32
Rank of the index in tab_index

Return Value

Returns the name of the .xml file

See Also

GoogleFI Class
ExportXML Overload


ExportXML Method (String)

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportXML Method (String)
GoogleFI Class Example See Also Send Feedback
This method allows you to export datas about an index in a .xml file.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportXML(
    string index
)
Visual Basic
Public Function ExportXML ( _
    index As String _
) As String
Visual C++
public:
String^ ExportXML(
    String^ index
)

Parameters

index
Type: System..::..String
Name of the index you want

Return Value

Returns the name of the .xml file

Examples

How to use it
CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
string s = g.ExportXML("GOOG");

See Also

GoogleFI Class
ExportXML Overload


ExportXML Method (Int32, String[])

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportXML Method (Int32, array<String>[]()[][])
GoogleFI Class See Also Send Feedback
This method allows you to export datas about an index in a .xml file, specifying options you want.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportXML(
    int index,
    string[] tab_donnee
)
Visual Basic
Public Function ExportXML ( _
    index As Integer, _
    tab_donnee As String() _
) As String
Visual C++
public:
String^ ExportXML(
    int index,
    array<String^>^ tab_donnee
)

Parameters

index
Type: System..::..Int32
Rank of the index in tab_index
tab_donnee
Type: array< System..::..String >[]()[][]
Tab which contains options you want

Return Value

Returns the name of the .xml file

See Also

GoogleFI Class
ExportXML Overload


ExportXML Method (String, String[])

[image]

Documentation of GoogleFiMag
GoogleFI..::..ExportXML Method (String, array<String>[]()[][])
GoogleFI Class Example See Also Send Feedback
This method allows you to export datas about an index in a .xml file, specifying options you want.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportXML(
    string index,
    string[] tab_donnee
)
Visual Basic
Public Function ExportXML ( _
    index As String, _
    tab_donnee As String() _
) As String
Visual C++
public:
String^ ExportXML(
    String^ index,
    array<String^>^ tab_donnee
)

Parameters

index
Type: System..::..String
Name of the index you want
tab_donnee
Type: array< System..::..String >[]()[][]
Tab which contains options you want

Return Value

Returns the name of the .xml file

Examples

CopyC#
GoogleFI g=new GoogleFI(tab_ind,begindate,enddate,frequency);
string[] tab = new tab[2] { "High","Low" };
string s = g.ExportXML("GOOG",tab);

See Also

GoogleFI Class
ExportXML Overload


getCompName Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..getCompName Method
GoogleFI Class See Also Send Feedback
get the name of the company when you give the ticker symbol

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string getCompName(
    string str
)
Visual Basic
Public Function getCompName ( _
    str As String _
) As String
Visual C++
public:
String^ getCompName(
    String^ str
)

Parameters

str
Type: System..::..String
ticker symbol

Return Value

company name

See Also

GoogleFI Class


getend Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..getend Method
GoogleFI Class See Also Send Feedback
access end

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime getend()
Visual Basic
Public Function getend As DateTime
Visual C++
public:
DateTime getend()

Return Value

end datet

See Also

GoogleFI Class


getfreq Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..getfreq Method
GoogleFI Class See Also Send Feedback
access freq

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int getfreq()
Visual Basic
Public Function getfreq As Integer
Visual C++
public:
int getfreq()

Return Value

freq

See Also

GoogleFI Class


getstart Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..getstart Method
GoogleFI Class See Also Send Feedback
access start

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime getstart()
Visual Basic
Public Function getstart As DateTime
Visual C++
public:
DateTime getstart()

Return Value

start_dates

See Also

GoogleFI Class


getTabIndex Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..getTabIndex Method
GoogleFI Class See Also Send Feedback
access tab_index

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string[] getTabIndex()
Visual Basic
Public Function getTabIndex As String()
Visual C++
public:
array<String^>^ getTabIndex()

Return Value

tab_index

See Also

GoogleFI Class


set_GoogleFI Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..set_GoogleFI Method
GoogleFI Class See Also Send Feedback
This method allows you to modify an instance of GoogleFI.

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void set_GoogleFI(
    string[] tab,
    DateTime datedebut,
    DateTime datefin,
    int frequence
)
Visual Basic
Public Sub set_GoogleFI ( _
    tab As String(), _
    datedebut As DateTime, _
    datefin As DateTime, _
    frequence As Integer _
)
Visual C++
public:
void set_GoogleFI(
    array<String^>^ tab,
    DateTime datedebut,
    DateTime datefin,
    int frequence
)

Parameters

tab
Type: array< System..::..String >[]()[][]
New tab of indexes
datedebut
Type: System..::..DateTime
New starting date
datefin
Type: System..::..DateTime
New ending date
frequence
Type: System..::..Int32
New frequency

See Also

GoogleFI Class


testIndex Method

[image]

Documentation of GoogleFiMag
GoogleFI..::..testIndex Method
GoogleFI Class See Also Send Feedback
Test if the reuters exists

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool testIndex(
    int index
)
Visual Basic
Public Function testIndex ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool testIndex(
    int index
)

Parameters

index
Type: System..::..Int32
index you want to lnow if it exists

Return Value

true if it exists

See Also

GoogleFI Class


historique Class

[image]

Documentation of GoogleFiMag
historique Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:GoogleFiMag.historique"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class historique : INotifyPropertyChanging, INotifyPropertyChanged
Visual Basic
Public Class historique _
    Implements INotifyPropertyChanging, INotifyPropertyChanged
Visual C++
public ref class historique : INotifyPropertyChanging,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
GoogleFiMag..::..historique

See Also

historique Members


historique Members

[image] [image]

Documentation of GoogleFiMag
historique Members
historique Class Constructors Methods Properties Events See Also Send Feedback

The historique type exposes the following members.

Constructors

 | Name | Description
Public method | historique | Initializes a new instance of the historique class

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | SendPropertyChanged |
Protected method | SendPropertyChanging |
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Date |
Public property | High |
Public property | Indice |
Public property | Low |
Public property | PriceClose |
Public property | PriceOpen |
Public property | Volume |

Events

 | Name | Description
Public event | PropertyChanged |
Public event | PropertyChanging |

See Also

historique Class


historique Constructor

[image]

Documentation of GoogleFiMag
historique Constructor
historique Class See Also Send Feedback
Initializes a new instance of the historique class

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public historique()
Visual Basic
Public Sub New
Visual C++
public:
historique()

See Also

historique Class


historique Methods

[image] [image]

Documentation of GoogleFiMag
historique Methods
historique Class See Also Send Feedback

The historique type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | SendPropertyChanged |
Protected method | SendPropertyChanging |
Public method | ToString | (Inherited from Object.)

See Also

historique Class


SendPropertyChanged Method

[image]

Documentation of GoogleFiMag
historique..::..SendPropertyChanged Method
historique Class See Also Send Feedback

[Missing <summary> documentation for "M:GoogleFiMag.historique.SendPropertyChanged(System.String)"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub SendPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void SendPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String

[Missing <param name="propertyName"/> documentation for "M:GoogleFiMag.historique.SendPropertyChanged(System.String)"]

See Also

historique Class


SendPropertyChanging Method

[image]

Documentation of GoogleFiMag
historique..::..SendPropertyChanging Method
historique Class See Also Send Feedback

[Missing <summary> documentation for "M:GoogleFiMag.historique.SendPropertyChanging"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void SendPropertyChanging()
Visual Basic
Protected Overridable Sub SendPropertyChanging
Visual C++
protected:
virtual void SendPropertyChanging()

See Also

historique Class


historique Properties

[image] [image]

Documentation of GoogleFiMag
historique Properties
historique Class See Also Send Feedback

The historique type exposes the following members.

Properties

 | Name | Description
Public property | Date |
Public property | High |
Public property | Indice |
Public property | Low |
Public property | PriceClose |
Public property | PriceOpen |
Public property | Volume |

See Also

historique Class


Date Property

[image]

Documentation of GoogleFiMag
historique..::..Date Property
historique Class See Also Send Feedback

[Missing <summary> documentation for "P:GoogleFiMag.historique.Date"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}

See Also

historique Class


High Property

[image]

Documentation of GoogleFiMag
historique..::..High Property
historique Class See Also Send Feedback

[Missing <summary> documentation for "P:GoogleFiMag.historique.High"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<double> High { get; set; }
Visual Basic
Public Property High As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> High {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

See Also

historique Class


Indice Property

[image]

Documentation of GoogleFiMag
historique..::..Indice Property
historique Class See Also Send Feedback

[Missing <summary> documentation for "P:GoogleFiMag.historique.Indice"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Indice { get; set; }
Visual Basic
Public Property Indice As String
    Get
    Set
Visual C++
public:
property String^ Indice {
    String^ get ();
    void set (String^ value);
}

See Also

historique Class


Low Property

[image]

Documentation of GoogleFiMag
historique..::..Low Property
historique Class See Also Send Feedback

[Missing <summary> documentation for "P:GoogleFiMag.historique.Low"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<double> Low { get; set; }
Visual Basic
Public Property Low As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Low {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

See Also

historique Class


PriceClose Property

[image]

Documentation of GoogleFiMag
historique..::..PriceClose Property
historique Class See Also Send Feedback

[Missing <summary> documentation for "P:GoogleFiMag.historique.PriceClose"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<double> PriceClose { get; set; }
Visual Basic
Public Property PriceClose As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> PriceClose {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

See Also

historique Class


PriceOpen Property

[image]

Documentation of GoogleFiMag
historique..::..PriceOpen Property
historique Class See Also Send Feedback

[Missing <summary> documentation for "P:GoogleFiMag.historique.PriceOpen"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<double> PriceOpen { get; set; }
Visual Basic
Public Property PriceOpen As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> PriceOpen {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

See Also

historique Class


Volume Property

[image]

Documentation of GoogleFiMag
historique..::..Volume Property
historique Class See Also Send Feedback

[Missing <summary> documentation for "P:GoogleFiMag.historique.Volume"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<double> Volume { get; set; }
Visual Basic
Public Property Volume As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Volume {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

See Also

historique Class


historique Events

[image] [image]

Documentation of GoogleFiMag
historique Events
historique Class See Also Send Feedback

The historique type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged |
Public event | PropertyChanging |

See Also

historique Class


PropertyChanged Event

[image]

Documentation of GoogleFiMag
historique..::..PropertyChanged Event
historique Class See Also Send Feedback

[Missing <summary> documentation for "E:GoogleFiMag.historique.PropertyChanged"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

historique Class


PropertyChanging Event

[image]

Documentation of GoogleFiMag
historique..::..PropertyChanging Event
historique Class See Also Send Feedback

[Missing <summary> documentation for "E:GoogleFiMag.historique.PropertyChanging"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangingEventHandler PropertyChanging
Visual Basic
Public Event PropertyChanging As PropertyChangingEventHandler
Visual C++
public:
virtual  event PropertyChangingEventHandler^ PropertyChanging {
    void add (PropertyChangingEventHandler^ value);
    void remove (PropertyChangingEventHandler^ value);
}

Implements

INotifyPropertyChanging..::..PropertyChanging

See Also

historique Class


linkDataContext Class

[image]

Documentation of GoogleFiMag
linkDataContext Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:GoogleFiMag.linkDataContext"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class linkDataContext : DataContext
Visual Basic
Public Class linkDataContext _
    Inherits DataContext
Visual C++
public ref class linkDataContext : public DataContext

Inheritance Hierarchy

System..::..Object
System.Data.Linq..::..DataContext
GoogleFiMag..::..linkDataContext

See Also

linkDataContext Members


linkDataContext Members

[image] [image]

Documentation of GoogleFiMag
linkDataContext Members
linkDataContext Class Constructors Methods Properties See Also Send Feedback

The linkDataContext type exposes the following members.

Constructors

 | Name | Description
Public method | linkDataContext()()()() | Initializes a new instance of the linkDataContext class
Public method | linkDataContext(IDbConnection) | Initializes a new instance of the linkDataContext class
Public method | linkDataContext(String) | Initializes a new instance of the linkDataContext class
Public method | linkDataContext(IDbConnection, MappingSource) | Initializes a new instance of the linkDataContext class
Public method | linkDataContext(String, MappingSource) | Initializes a new instance of the linkDataContext class

Methods

 | Name | Description
Public method | CreateDatabase | (Inherited from DataContext.)
Protected method | CreateMethodCallQuery<(Of <<'(TResult>)>>) | (Inherited from DataContext.)
Public method | DatabaseExists | (Inherited from DataContext.)
Public method | DeleteDatabase | (Inherited from DataContext.)
Public method | Dispose()()()() | (Inherited from DataContext.)
Protected method | Dispose(Boolean) | (Inherited from DataContext.)
Public method | Equals | (Inherited from Object.)
Public method | ExecuteCommand | (Inherited from DataContext.)
Protected method | ExecuteDynamicDelete | (Inherited from DataContext.)
Protected method | ExecuteDynamicInsert | (Inherited from DataContext.)
Protected method | ExecuteDynamicUpdate | (Inherited from DataContext.)
Protected method | ExecuteMethodCall | (Inherited from DataContext.)
Public method | ExecuteQuery(Type, String, array<Object>[]()[][]) | (Inherited from DataContext.)
Public method | ExecuteQuery<(Of <<'(TResult>)>>)(String, array<Object>[]()[][]) | (Inherited from DataContext.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetChangeSet | (Inherited from DataContext.)
Public method | GetCommand | (Inherited from DataContext.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTable(Type) | (Inherited from DataContext.)
Public method | GetTable<(Of <<'(TEntity>)>>)()()()() | (Inherited from DataContext.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Refresh(RefreshMode, Object) | (Inherited from DataContext.)
Public method | Refresh(RefreshMode, array<Object>[]()[][]) | (Inherited from DataContext.)
Public method | Refresh(RefreshMode, IEnumerable) | (Inherited from DataContext.)
Public method | SubmitChanges()()()() | (Inherited from DataContext.)
Public method | SubmitChanges(ConflictMode) | (Inherited from DataContext.)
Public method | ToString | (Inherited from Object.)
Public method | Translate(Type, DbDataReader) | (Inherited from DataContext.)
Public method | Translate<(Of <<'(TResult>)>>)(DbDataReader) | (Inherited from DataContext.)

Properties

 | Name | Description
Public property | ChangeConflicts | (Inherited from DataContext.)
Public property | CommandTimeout | (Inherited from DataContext.)
Public property | Connection | (Inherited from DataContext.)
Public property | DeferredLoadingEnabled | (Inherited from DataContext.)
Public property | historique |
Public property | LoadOptions | (Inherited from DataContext.)
Public property | Log | (Inherited from DataContext.)
Public property | Mapping | (Inherited from DataContext.)
Public property | ObjectTrackingEnabled | (Inherited from DataContext.)
Public property | Transaction | (Inherited from DataContext.)

See Also

linkDataContext Class


linkDataContext Constructor

[image] [image]

Documentation of GoogleFiMag
linkDataContext Constructor
linkDataContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | linkDataContext()()()() | Initializes a new instance of the linkDataContext class
Public method | linkDataContext(IDbConnection) | Initializes a new instance of the linkDataContext class
Public method | linkDataContext(String) | Initializes a new instance of the linkDataContext class
Public method | linkDataContext(IDbConnection, MappingSource) | Initializes a new instance of the linkDataContext class
Public method | linkDataContext(String, MappingSource) | Initializes a new instance of the linkDataContext class

See Also

linkDataContext Class
linkDataContext Members


linkDataContext Constructor

[image]

Documentation of GoogleFiMag
linkDataContext Constructor
linkDataContext Class See Also Send Feedback
Initializes a new instance of the linkDataContext class

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public linkDataContext()
Visual Basic
Public Sub New
Visual C++
public:
linkDataContext()

See Also

linkDataContext Class
linkDataContext Overload


linkDataContext Constructor (IDbConnection)

[image]

Documentation of GoogleFiMag
linkDataContext Constructor (IDbConnection)
linkDataContext Class See Also Send Feedback
Initializes a new instance of the linkDataContext class

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public linkDataContext(
    IDbConnection connection
)
Visual Basic
Public Sub New ( _
    connection As IDbConnection _
)
Visual C++
public:
linkDataContext(
    IDbConnection^ connection
)

Parameters

connection
Type: System.Data..::..IDbConnection

[Missing <param name="connection"/> documentation for "M:GoogleFiMag.linkDataContext.#ctor(System.Data.IDbConnection)"]

See Also

linkDataContext Class
linkDataContext Overload


linkDataContext Constructor (String)

[image]

Documentation of GoogleFiMag
linkDataContext Constructor (String)
linkDataContext Class See Also Send Feedback
Initializes a new instance of the linkDataContext class

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public linkDataContext(
    string connection
)
Visual Basic
Public Sub New ( _
    connection As String _
)
Visual C++
public:
linkDataContext(
    String^ connection
)

Parameters

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:GoogleFiMag.linkDataContext.#ctor(System.String)"]

See Also

linkDataContext Class
linkDataContext Overload


linkDataContext Constructor (IDbConnection, MappingSource)

[image]

Documentation of GoogleFiMag
linkDataContext Constructor (IDbConnection, MappingSource)
linkDataContext Class See Also Send Feedback
Initializes a new instance of the linkDataContext class

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public linkDataContext(
    IDbConnection connection,
    MappingSource mappingSource
)
Visual Basic
Public Sub New ( _
    connection As IDbConnection, _
    mappingSource As MappingSource _
)
Visual C++
public:
linkDataContext(
    IDbConnection^ connection,
    MappingSource^ mappingSource
)

Parameters

connection
Type: System.Data..::..IDbConnection

[Missing <param name="connection"/> documentation for "M:GoogleFiMag.linkDataContext.#ctor(System.Data.IDbConnection,System.Data.Linq.Mapping.MappingSource)"]

mappingSource
Type: System.Data.Linq.Mapping..::..MappingSource

[Missing <param name="mappingSource"/> documentation for "M:GoogleFiMag.linkDataContext.#ctor(System.Data.IDbConnection,System.Data.Linq.Mapping.MappingSource)"]

See Also

linkDataContext Class
linkDataContext Overload


linkDataContext Constructor (String, MappingSource)

[image]

Documentation of GoogleFiMag
linkDataContext Constructor (String, MappingSource)
linkDataContext Class See Also Send Feedback
Initializes a new instance of the linkDataContext class

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public linkDataContext(
    string connection,
    MappingSource mappingSource
)
Visual Basic
Public Sub New ( _
    connection As String, _
    mappingSource As MappingSource _
)
Visual C++
public:
linkDataContext(
    String^ connection,
    MappingSource^ mappingSource
)

Parameters

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:GoogleFiMag.linkDataContext.#ctor(System.String,System.Data.Linq.Mapping.MappingSource)"]

mappingSource
Type: System.Data.Linq.Mapping..::..MappingSource

[Missing <param name="mappingSource"/> documentation for "M:GoogleFiMag.linkDataContext.#ctor(System.String,System.Data.Linq.Mapping.MappingSource)"]

See Also

linkDataContext Class
linkDataContext Overload


linkDataContext Methods

[image] [image]

Documentation of GoogleFiMag
linkDataContext Methods
linkDataContext Class See Also Send Feedback

The linkDataContext type exposes the following members.

Methods

 | Name | Description
Public method | CreateDatabase | (Inherited from DataContext.)
Protected method | CreateMethodCallQuery<(Of <<'(TResult>)>>) | (Inherited from DataContext.)
Public method | DatabaseExists | (Inherited from DataContext.)
Public method | DeleteDatabase | (Inherited from DataContext.)
Public method | Dispose()()()() | (Inherited from DataContext.)
Protected method | Dispose(Boolean) | (Inherited from DataContext.)
Public method | Equals | (Inherited from Object.)
Public method | ExecuteCommand | (Inherited from DataContext.)
Protected method | ExecuteDynamicDelete | (Inherited from DataContext.)
Protected method | ExecuteDynamicInsert | (Inherited from DataContext.)
Protected method | ExecuteDynamicUpdate | (Inherited from DataContext.)
Protected method | ExecuteMethodCall | (Inherited from DataContext.)
Public method | ExecuteQuery(Type, String, array<Object>[]()[][]) | (Inherited from DataContext.)
Public method | ExecuteQuery<(Of <<'(TResult>)>>)(String, array<Object>[]()[][]) | (Inherited from DataContext.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetChangeSet | (Inherited from DataContext.)
Public method | GetCommand | (Inherited from DataContext.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTable(Type) | (Inherited from DataContext.)
Public method | GetTable<(Of <<'(TEntity>)>>)()()()() | (Inherited from DataContext.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Refresh(RefreshMode, Object) | (Inherited from DataContext.)
Public method | Refresh(RefreshMode, array<Object>[]()[][]) | (Inherited from DataContext.)
Public method | Refresh(RefreshMode, IEnumerable) | (Inherited from DataContext.)
Public method | SubmitChanges()()()() | (Inherited from DataContext.)
Public method | SubmitChanges(ConflictMode) | (Inherited from DataContext.)
Public method | ToString | (Inherited from Object.)
Public method | Translate(Type, DbDataReader) | (Inherited from DataContext.)
Public method | Translate<(Of <<'(TResult>)>>)(DbDataReader) | (Inherited from DataContext.)

See Also

linkDataContext Class


Dispose Method

[image] [image]

Documentation of GoogleFiMag
linkDataContext..::..Dispose Method
linkDataContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | (Inherited from DataContext.)
Protected method | Dispose(Boolean) | (Inherited from DataContext.)

See Also

linkDataContext Class
linkDataContext Members


ExecuteQuery Method

[image] [image]

Documentation of GoogleFiMag
linkDataContext..::..ExecuteQuery Method
linkDataContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExecuteQuery<(Of <<'(TResult>)>>)(String, array<Object>[]()[][]) | (Inherited from DataContext.)
Public method | ExecuteQuery(Type, String, array<Object>[]()[][]) | (Inherited from DataContext.)

See Also

linkDataContext Class
linkDataContext Members


GetTable Method

[image] [image]

Documentation of GoogleFiMag
linkDataContext..::..GetTable Method
linkDataContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTable<(Of <<'(TEntity>)>>)()()()() | (Inherited from DataContext.)
Public method | GetTable(Type) | (Inherited from DataContext.)

See Also

linkDataContext Class
linkDataContext Members


Refresh Method

[image] [image]

Documentation of GoogleFiMag
linkDataContext..::..Refresh Method
linkDataContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Refresh(RefreshMode, Object) | (Inherited from DataContext.)
Public method | Refresh(RefreshMode, array<Object>[]()[][]) | (Inherited from DataContext.)
Public method | Refresh(RefreshMode, IEnumerable) | (Inherited from DataContext.)

See Also

linkDataContext Class
linkDataContext Members


SubmitChanges Method

[image] [image]

Documentation of GoogleFiMag
linkDataContext..::..SubmitChanges Method
linkDataContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SubmitChanges()()()() | (Inherited from DataContext.)
Public method | SubmitChanges(ConflictMode) | (Inherited from DataContext.)

See Also

linkDataContext Class
linkDataContext Members


Translate Method

[image] [image]

Documentation of GoogleFiMag
linkDataContext..::..Translate Method
linkDataContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Translate<(Of <<'(TResult>)>>)(DbDataReader) | (Inherited from DataContext.)
Public method | Translate(Type, DbDataReader) | (Inherited from DataContext.)

See Also

linkDataContext Class
linkDataContext Members


linkDataContext Properties

[image] [image]

Documentation of GoogleFiMag
linkDataContext Properties
linkDataContext Class See Also Send Feedback

The linkDataContext type exposes the following members.

Properties

 | Name | Description
Public property | ChangeConflicts | (Inherited from DataContext.)
Public property | CommandTimeout | (Inherited from DataContext.)
Public property | Connection | (Inherited from DataContext.)
Public property | DeferredLoadingEnabled | (Inherited from DataContext.)
Public property | historique |
Public property | LoadOptions | (Inherited from DataContext.)
Public property | Log | (Inherited from DataContext.)
Public property | Mapping | (Inherited from DataContext.)
Public property | ObjectTrackingEnabled | (Inherited from DataContext.)
Public property | Transaction | (Inherited from DataContext.)

See Also

linkDataContext Class


historique Property

[image]

Documentation of GoogleFiMag
linkDataContext..::..historique Property
linkDataContext Class See Also Send Feedback

[Missing <summary> documentation for "P:GoogleFiMag.linkDataContext.historique"]

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Table<historique> historique { get; }
Visual Basic
Public ReadOnly Property historique As Table(Of historique)
    Get
Visual C++
public:
property Table<historique^>^ historique {
    Table<historique^>^ get ();
}

See Also

linkDataContext Class


parserxml Class

[image]

Documentation of GoogleFiMag
parserxml Class
Members See Also Send Feedback
Parses a xml file

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class parserxml
Visual Basic
Public NotInheritable Class parserxml
Visual C++
public ref class parserxml abstract sealed

Inheritance Hierarchy

System..::..Object
GoogleFiMag..::..parserxml

See Also

parserxml Members


parserxml Members

[image] [image]

Documentation of GoogleFiMag
parserxml Members
parserxml Class Methods See Also Send Feedback

Methods

Name | Description
readxml(String) | Reads a xml file and retrieves the financial data
readxml(String, array<String>[]()[][]%, String%, String%, array<String>[]()[][]%) | Reads a xml file and retrieves the financial data

See Also

parserxml Class


parserxml Methods

[image] [image]

Documentation of GoogleFiMag
parserxml Methods
parserxml Class See Also Send Feedback

Methods

Name | Description
readxml(String) | Reads a xml file and retrieves the financial data
readxml(String, array<String>[]()[][]%, String%, String%, array<String>[]()[][]%) | Reads a xml file and retrieves the financial data

See Also

parserxml Class


readxml Method

[image] [image]

Documentation of GoogleFiMag
parserxml..::..readxml Method
parserxml Class See Also Send Feedback

Overload List

Name | Description
readxml(String) | Reads a xml file and retrieves the financial data
readxml(String, array<String>[]()[][]%, String%, String%, array<String>[]()[][]%) | Reads a xml file and retrieves the financial data

See Also

parserxml Class
parserxml Members


readxml Method (String)

[image]

Documentation of GoogleFiMag
parserxml..::..readxml Method (String)
parserxml Class See Also Send Feedback
Reads a xml file and retrieves the financial data

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static GoogleFI readxml(
    string nomfichier
)
Visual Basic
Public Shared Function readxml ( _
    nomfichier As String _
) As GoogleFI
Visual C++
public:
static GoogleFI^ readxml(
    String^ nomfichier
)

Parameters

nomfichier
Type: System..::..String
Name of the xml file

Return Value

A GoogleFi Object which contains the data

Exceptions

Exception | Condition
System..::..Exception | Trying to export in several formats

See Also

parserxml Class
readxml Overload


readxml Method (String, String[], String, String, String[])

[image]

Documentation of GoogleFiMag
parserxml..::..readxml Method (String, array<String>[]()[][]%, String%, String%, array<String>[]()[][]%)
parserxml Class See Also Send Feedback
Reads a xml file and retrieves the financial data

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static GoogleFI readxml(
    string nomfichier,
    out string[] tab_champ,
    out string typeexport,
    out string nameexport,
    out string[] exportBDD
)
Visual Basic
Public Shared Function readxml ( _
    nomfichier As String, _
    <OutAttribute> ByRef tab_champ As String(), _
    <OutAttribute> ByRef typeexport As String, _
    <OutAttribute> ByRef nameexport As String, _
    <OutAttribute> ByRef exportBDD As String() _
) As GoogleFI
Visual C++
public:
static GoogleFI^ readxml(
    String^ nomfichier,
    [OutAttribute] array<String^>^% tab_champ,
    [OutAttribute] String^% typeexport,
    [OutAttribute] String^% nameexport,
    [OutAttribute] array<String^>^% exportBDD
)

Parameters

nomfichier
Type: System..::..String
Name of the xml file
tab_champ
Type: array< System..::..String >[]()[][]%
Contains the fields of observation
typeexport
Type: System..::..String %
Represents the type of exportation
nameexport
Type: System..::..String %
Adress of the exported file
exportBDD
Type: array< System..::..String >[]()[][]%
Parameters of a database exportation

Return Value

A GoogleFi Object which contains the data

Exceptions

Exception | Condition
System..::..Exception | Trying to export in several formats

See Also

parserxml Class
readxml Overload


UnknownIndexException Class

[image]

Documentation of GoogleFiMag
UnknownIndexException Class
Members See Also Send Feedback
Exception thrown when the index is unknown on GOOGLE FINANCE

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UnknownIndexException : Exception
Visual Basic
Public Class UnknownIndexException _
    Inherits Exception
Visual C++
public ref class UnknownIndexException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
GoogleFiMag..::..UnknownIndexException

See Also

UnknownIndexException Members


UnknownIndexException Members

[image] [image]

Documentation of GoogleFiMag
UnknownIndexException Members
UnknownIndexException Class Constructors Methods Properties Events See Also Send Feedback

The UnknownIndexException type exposes the following members.

Constructors

 | Name | Description
Public method | UnknownIndexException()()()() | Constructor
Public method | UnknownIndexException(String) | Constructor with specifie index

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | getError | to get the error and the index which caused the error in the same string
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Protected property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | (Inherited from Exception.)

See Also

UnknownIndexException Class


UnknownIndexException Constructor

[image] [image]

Documentation of GoogleFiMag
UnknownIndexException Constructor
UnknownIndexException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnknownIndexException()()()() | Constructor
Public method | UnknownIndexException(String) | Constructor with specifie index

See Also

UnknownIndexException Class
UnknownIndexException Members


UnknownIndexException Constructor

[image]

Documentation of GoogleFiMag
UnknownIndexException Constructor
UnknownIndexException Class See Also Send Feedback
Constructor

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UnknownIndexException()
Visual Basic
Public Sub New
Visual C++
public:
UnknownIndexException()

See Also

UnknownIndexException Class
UnknownIndexException Overload


UnknownIndexException Constructor (String)

[image]

Documentation of GoogleFiMag
UnknownIndexException Constructor (String)
UnknownIndexException Class See Also Send Feedback
Constructor with specifie index

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UnknownIndexException(
    string index_
)
Visual Basic
Public Sub New ( _
    index_ As String _
)
Visual C++
public:
UnknownIndexException(
    String^ index_
)

Parameters

index_
Type: System..::..String
the index specific wich dose'nt existe

See Also

UnknownIndexException Class
UnknownIndexException Overload


UnknownIndexException Methods

[image] [image]

Documentation of GoogleFiMag
UnknownIndexException Methods
UnknownIndexException Class See Also Send Feedback

The UnknownIndexException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | getError | to get the error and the index which caused the error in the same string
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)

See Also

UnknownIndexException Class


getError Method

[image]

Documentation of GoogleFiMag
UnknownIndexException..::..getError Method
UnknownIndexException Class See Also Send Feedback
to get the error and the index which caused the error in the same string

Namespace: GoogleFiMag
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string getError()
Visual Basic
Public Function getError As String
Visual C++
public:
String^ getError()

Return Value

the string with the message and the false index

See Also

UnknownIndexException Class


UnknownIndexException Properties

[image] [image]

Documentation of GoogleFiMag
UnknownIndexException Properties
UnknownIndexException Class See Also Send Feedback

The UnknownIndexException type exposes the following members.

Properties

 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Protected property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)

See Also

UnknownIndexException Class


UnknownIndexException Events

[image] [image]

Documentation of GoogleFiMag
UnknownIndexException Events
UnknownIndexException Class See Also Send Feedback

The UnknownIndexException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | (Inherited from Exception.)

See Also

UnknownIndexException Class


GoogleFiMag.Properties Namespace

[image]

Documentation of GoogleFiMag
GoogleFiMag.Properties Namespace
Send Feedback

[Missing <summary> documentation for "N:GoogleFiMag.Properties"]

Classes

 | Class | Description
Public class | Resources | Une classe de ressource fortement typée destinée, entre autres, à la consultation des chaînes localisées.


Resources Class

[image]

Documentation of GoogleFiMag
Resources Class
Members See Also Send Feedback
Une classe de ressource fortement typée destinée, entre autres, à la consultation des chaînes localisées.

Namespace: GoogleFiMag.Properties
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Resources
Visual Basic
Public Class Resources
Visual C++
public ref class Resources

Inheritance Hierarchy

System..::..Object
GoogleFiMag.Properties..::..Resources

See Also

Resources Members
GoogleFiMag.Properties Namespace


Resources Members

[image] [image]

Documentation of GoogleFiMag
Resources Members
Resources Class Methods Properties See Also Send Feedback

The Resources type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
Culture | Remplace la propriété CurrentUICulture du thread actuel pour toutes les recherches de ressources à l'aide de cette classe de ressource fortement typée.
export | this is a ressoure of the DLL, a file export.mdf. whitout it you can't create the database to export in mdf So it's is inside the DLL and created dynamically whenever it's needed
ResourceManager | Retourne l'instance ResourceManager mise en cache utilisée par cette classe.

See Also

Resources Class
GoogleFiMag.Properties Namespace


Resources Methods

[image] [image]

Documentation of GoogleFiMag
Resources Methods
Resources Class See Also Send Feedback

The Resources type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Resources Class
GoogleFiMag.Properties Namespace


Resources Properties

[image] [image]

Documentation of GoogleFiMag
Resources Properties
Resources Class See Also Send Feedback

The Resources type exposes the following members.

Properties

Name | Description
Culture | Remplace la propriété CurrentUICulture du thread actuel pour toutes les recherches de ressources à l'aide de cette classe de ressource fortement typée.
export | this is a ressoure of the DLL, a file export.mdf. whitout it you can't create the database to export in mdf So it's is inside the DLL and created dynamically whenever it's needed
ResourceManager | Retourne l'instance ResourceManager mise en cache utilisée par cette classe.

See Also

Resources Class
GoogleFiMag.Properties Namespace


Culture Property

[image]

Documentation of GoogleFiMag
Resources..::..Culture Property
Resources Class See Also Send Feedback
Remplace la propriété CurrentUICulture du thread actuel pour toutes les recherches de ressources à l'aide de cette classe de ressource fortement typée.

Namespace: GoogleFiMag.Properties
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static CultureInfo Culture { get; set; }
Visual Basic
Public Shared Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
static property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

Resources Class
GoogleFiMag.Properties Namespace


export Property

[image]

Documentation of GoogleFiMag
Resources..::..export Property
Resources Class See Also Send Feedback
this is a ressoure of the DLL, a file export.mdf. whitout it you can't create the database to export in mdf So it's is inside the DLL and created dynamically whenever it's needed

Namespace: GoogleFiMag.Properties
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static byte[] export { get; }
Visual Basic
Public Shared ReadOnly Property export As Byte()
    Get
Visual C++
public:
static property array<unsigned char>^ export {
    array<unsigned char>^ get ();
}

See Also

Resources Class
GoogleFiMag.Properties Namespace


ResourceManager Property

[image]

Documentation of GoogleFiMag
Resources..::..ResourceManager Property
Resources Class See Also Send Feedback
Retourne l'instance ResourceManager mise en cache utilisée par cette classe.

Namespace: GoogleFiMag.Properties
Assembly: GoogleFiMag (in GoogleFiMag.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ResourceManager ResourceManager { get; }
Visual Basic
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get
Visual C++
public:
static property ResourceManager^ ResourceManager {
    ResourceManager^ get ();
}

See Also

Resources Class
GoogleFiMag.Properties Namespace